Delayed GCP data delivery of cost and usage since February 11, 2026

Incident Report for DoiT International

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 07:31 UTC

Monitoring

GCP data delivery appears to be stabilizing. Our team is actively processing and backfilling the missing data into the DoiT platform.
This process may take several hours to complete. We appreciate your patience.
Posted Feb 17, 2026 - 08:49 UTC

Identified

We have identified a delay in the delivery of Google Cloud Platform (GCP) cost and usage data.
Our team is working with GCP to resolve the issue and is carefully monitoring data ingestion into the DoiT Console.
At this time, recent GCP cost and usage data might seem delayed or incomplete.
Our team is working diligently to restore normal reporting as soon as possible.
We appreciate your patience in the meantime.
Posted Feb 16, 2026 - 08:31 UTC