Google Workspace / Office365 - Issue with adding/removing licenses
Incident Report for DoiT International
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 18:14 UTC
Investigating
Clients may be unable to add and remove licenses for their Workspace subscriptions. The engineering teams are investigating this issue.
Posted Mar 13, 2023 - 11:56 UTC
This incident affected: Core Platform (Dashboards).