Google billing data ingestion incomplete for some customers since April 25

Incident Report for DoiT International

Monitoring

Google has completed the backfill operation, but currently, the refreshed data is not consistently visible across all customer accounts. Our ingestion pipelines are still finalising the processing of the latest update. We are closely monitoring the progress and expect the issue to be fully resolved soon.
Posted Apr 29, 2025 - 11:29 UTC

Identified

We would like to inform you that GCP billing data for a subset of customers has been missing or incomplete since April 25, 2025.
Our team has identified the root cause of the issue and is actively working on a resolution to restore full data integrity.
We sincerely appreciate your understanding and patience as we work to resolve this matter as quickly as possible.
We will provide further updates as progress is made.
Posted Apr 28, 2025 - 09:01 UTC
This incident affects: Core Platform (Cloud Cost Analytics, Dashboards).