investigating an increased level of 500 errors for customers

Incident Report for DoiT International

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 12:11 UTC

Update

We are continuing to investigate this issue.
Posted Oct 23, 2025 - 12:02 UTC

Update

We are continuing to investigate this issue.
Posted Oct 23, 2025 - 05:50 UTC

Investigating

We are continuing to investigate the issue. It appears the error originated from Cloudflare.
You can track the status here: https://www.cloudflarestatus.com/
Posted Oct 23, 2025 - 05:06 UTC
This incident affected: Core Platform (Support & Consulting, Cloud Cost Analytics, Flexsave, Dashboards, Anomaly Detection, DoiT Console, Billing).