AWS invoices missing Support charges

Incident Report for DoiT International

Resolved

This issue has been resolved.
Posted Apr 14, 2025 - 06:45 UTC

Identified

Due to a problem in our billing pipeline, some invoices are missing AWS support totals. Engineers are working to update this, after which invoices for affected customers will be cancelled and re-issued.
Posted Apr 09, 2025 - 18:09 UTC
This incident affected: Core Platform (Billing).