Inaccurate AWS Cost Data

Incident Report for DoiT International

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 00:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 16, 2026 - 19:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2026 - 19:43 UTC

Investigating

We are currently monitoring an external service event from AWS “AWS BILLING OPERATIONAL ISSUE” in us-east-1, which is impacting the accuracy of cost data. This AWS-side issue began on February 13, 2026, and affects Cost Explorer, the AWS Billing Console, and Cost and Usage Report (CUR) exports. Because the DoiT Console relies directly on these AWS data feeds, cost reports and dashboards for usage since February 1, 2026, may temporarily display incomplete, delayed, or zeroed-out values.

AWS has confirmed they are in the process of regenerating cost data for all affected services to correct these discrepancies.

Our team is tracking the situation closely and waiting for AWS to finalize their data regeneration. We will provide a follow-up update once AWS confirms that their billing exports are once again complete and accurate.
Posted Feb 16, 2026 - 19:43 UTC
This incident affected: Core Platform (Cloud Cost Analytics).