Issue with editing Billing Profiles & Paying Invoices
Incident Report for DoiT International
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 20:24 UTC
Investigating
Customers are currently unable to edit their billing profiles or complete invoice payments.
This issue stems from a third-party service dependency, and while we are closely monitoring the situation and engaging with the provider, resolution is outside of our direct control. We appreciate your patience as we work to restore full functionality as soon as possible.
Posted Jan 13, 2025 - 19:34 UTC
This incident affected: Core Platform (Billing).