Incorrect Billing Data for AWS Saving Plans in June 2024 Invoices Detected
Incident Report for DoiT International
Resolved
The issue has been resolved, and we will be issuing new invoices to our affected customers.
Posted Jul 06, 2024 - 11:11 UTC
Investigating
We have identified an issue impacting a subset of AWS customers concerning the cost type of SPs in their June 2024 invoices.
Posted Jul 05, 2024 - 17:08 UTC
This incident affected: Core Platform (Cloud Cost Analytics).