The "Create a request' feature is temporarily unavailable for some customers

Incident Report for DoiT International

Resolved

We are happy to inform you that the issue has been fixed, and all affected customers can now submit new requests. Thank you for your patience and understanding.
Posted Jul 04, 2025 - 07:30 UTC

Identified

An issue has been identified with creating new requests on the DoiT platform.
As a result, some users may experience issues or be unable to create new requests on the platform's "Expert inquiry" dashboard.

Our engineering teams are currently addressing this issue and will share updates promptly as more information emerges.
Posted Jul 04, 2025 - 06:55 UTC
This incident affected: Core Platform (Support & Consulting).