Email Delivery Disruption

Incident Report for DoiT International

Resolved

The issue with our email service provider has been fully resolved. Email delivery is now operating normally across all features.
Posted Aug 31, 2025 - 15:05 UTC

Identified

We have identified an issue with our email service provider that is preventing emails from being sent. This may impact user invitations, alerts, budgets, cost anomaly notifications, and other email-based features.

Our team is actively working to resolve the issue and will provide updates as they become available.
Posted Aug 31, 2025 - 10:10 UTC
This incident affected: Core Platform (DoiT Console).