DoiT Console unavailability

Incident Report for DoiT International

Resolved

This incident has now been resolved.
Posted Jun 12, 2025 - 18:57 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:42 UTC

Investigating

We are currently experiencing disruption due to a global Google Cloud outage. As a result, some of our services — including access to and usage of the DoiT Console — may be intermittently affected.

Our engineering teams are actively monitoring the situation and working closely with Google to track progress. We will provide timely updates as more information becomes available.
Posted Jun 12, 2025 - 18:33 UTC
This incident affected: Core Platform (Support & Consulting, Cloud Cost Analytics, APIs, Dashboards, Anomaly Detection, DoiT Console, Billing).