BigQuery Lens: Incorrect Storage Metrics

Incident Report for DoiT International

Update

We are continuing to work on a fix for this issue.
Posted Oct 25, 2025 - 20:26 UTC

Identified

We are pleased to update you that our team has identified the root cause causing misclassification and inflated storage metrics in BigQuery Lens.
We appreciate your patience in the meantime.
Posted Oct 24, 2025 - 11:18 UTC

Investigating

We have detected and are investigating an issue where storage-related metrics in BigQuery Lens (for example, Storage price in the Explorer widget and related recommendations) may display inflated or otherwise incorrect values for some projects or datasets.
Our engineering team is currently investigating the issue, and we appreciate your patience during this time.
Posted Oct 23, 2025 - 08:58 UTC
This incident affects: Core Platform (Cloud Cost Analytics, Dashboards).