Missing Google Cloud Billing Data

Incident Report for DoiT International

Resolved

The incident has been resolved and we are now seeing normal incoming billing data from GCP
Posted Aug 07, 2025 - 09:47 UTC

Monitoring

We are still seeing delays and missing data from the past few days. We are communicating with Google engineering team and this is handled with the highest priority. The Google incident is still open and you can follow it here:
https://console.cloud.google.com/servicehealth/incidents?pageState=(%22psh_incidents_list_v2%22:(%22p%22:0,%22service%22:%5B%22Cloud%20Billing%22%5D))
Posted Aug 06, 2025 - 07:48 UTC

Update

This is the latest update from Google Cloud team:
"Our engineering team continues to address the data delays for the billing data exports to BigQuery. As a result of the mitigation implemented by the engineering team, the data delays continue to reduce in the billing exports to BigQuery. The system is now processing the data backlog and we are actively monitoring the progress of full recovery of billing data exports to BigQuery."

Google incident: https://console.cloud.google.com/servicehealth/incidents?pageState=(%22psh_incidents_list_v2%22:(%22p%22:0,%22service%22:%5B%22Cloud%20Billing%22%5D))
Posted Aug 05, 2025 - 07:09 UTC

Identified

The issue is identified as a Google billing export to BQ. Google team is working on fixing the issue. Google incident: https://console.cloud.google.com/servicehealth/incidents?pageState=(%22psh_incidents_list_v2%22:(%22p%22:0,%22service%22:%5B%22Cloud%20Billing%22%5D))
Posted Aug 03, 2025 - 15:44 UTC

Investigating

We are currently investigating a possible outage from Google resulting in missing Google Cloud billing data
Posted Aug 03, 2025 - 15:39 UTC
This incident affected: Core Platform (Cloud Cost Analytics, Dashboards, Anomaly Detection, DoiT Console, Billing).