Issue with editing Billing Profiles & Paying Invoices
Incident Report for DoiT International
Resolved
We are happy to advise this issue has now been resolved. Thank you for your patience whilst we worked through the incident.
Posted Dec 24, 2024 - 08:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 23, 2024 - 11:49 UTC
Investigating
Customers may experience and issue when creating or editing Billing Profiles & paying Invoices via the DoiT console. Our Engineering Team are actively investigating the cause of this issue and we will provide updates on our progress shortly.
Posted Dec 23, 2024 - 11:07 UTC
This incident affected: Core Platform (DoiT Console, Invoicing).