GCP Billing and Invoicing Issue - December 2024

Incident Report for DoiT International

Resolved

The invoices for all affected GCP customers were generated and are being sent out today.
Posted Jan 28, 2025 - 18:24 UTC

Update

We are currently in the final stages of resolving all the December 2024 billing cycle invoices.
An update will be sent once all invoices are ready and available.

Thank you for your patience.
Posted Jan 23, 2025 - 12:30 UTC

Identified

We've found an issue with our billing and invoicing for a subset of GCP customers for December 2024.
The issue has been identified, and the team is busy working on a fix. After the fix has been implemented, new invoices will be issued.
Posted Jan 22, 2025 - 10:31 UTC
This incident affected: Core Platform (Billing).