Microsoft 365 and Google Workspace Invoice Issues
Incident Report for DoiT International
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 07:39 UTC
Monitoring
The problem with our Office365 and Google Workspace invoices has been rectified and we are working to send them out today.
Posted Sep 04, 2024 - 08:09 UTC
Identified
Due to a technical issue there will be a delay in the issuing of Microsoft 365 and Google Workspace Invoices
Posted Sep 03, 2024 - 08:21 UTC
This incident affected: Core Platform (Invoicing).