Inaccurate AWS Billing Data
Incident Report for DoiT International
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 06:48 UTC
Update
We're actively keeping an eye on the situation. As of now, we've successfully processed 91% of the corrected data from AWS. We'll provide you with regular updates on our progress.
Posted Aug 21, 2023 - 18:09 UTC
Update
The problem has been resolved by AWS. However, we are currently in the process of waiting for data to be transferred into our systems. At the moment, 66% of the corrected information is already available, and we are awaiting the remaining 34%. No timeline has been provided by AWS.
Posted Aug 18, 2023 - 12:07 UTC
Update
AWS is currently in the process of restoring the final segment of data, and are anticipate the entire restoration to be completed by 1:00 PM PDT on August 16. It will take 24 hours for the changes to be reflected in your CE (Cost Explorer) and CUR (Cost Usage Report) after the restoration is completed. AWS will share next update once data has been completely restored.
Posted Aug 16, 2023 - 19:55 UTC
Update
Data Discrepancy Issues with the AWS Billing Console
AWS confirmed that the majority of incorrect data has been corrected. Impacted customers will still see signs of incorrect data from August 1, 2023, until August 13th, 2023, and would experience incremental recovery in the lost usage data until it is fully recovered. AWS will continue to work on addressing the backlog of incorrect data at an accelerated pace, and will provide next update by August 16, 11:00 AM PDT.
Posted Aug 16, 2023 - 11:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2023 - 19:14 UTC
Update
AWS has implemented a solution that effectively addresses the problem. They are actively striving to expedite the resolution of the backlog of inaccurate data. Affected clients may continue to observe incorrect data until the backlog is rectified. AWS will provide a further update after the backlog has been successfully cleared. The problem has been resolved, and the service is presently functioning without any issues.
Posted Aug 14, 2023 - 19:12 UTC
Update
AWS has identified the root cause of the data discrepancy issues in the Billing Console and the engineering team has already deployed a fix to mitigate the identified root cause. The team has started the process of filling the backlog of incorrect data.
Posted Aug 14, 2023 - 17:54 UTC
Update
AWS acknowledged the issue and is presently looking into the matter and anticipates sharing an update later today.
Posted Aug 14, 2023 - 15:00 UTC
Identified
We are receiving inaccurate billing data from AWS which impacts Cloud Analytics, Flexsave and Anomaly Detection.
Posted Aug 14, 2023 - 07:58 UTC
This incident affected: Core Platform (Cloud Cost Analytics, Flexsave, Anomaly Detection).