Invoice PDF attachments missing from the Invoices dashboard
Incident Report for DoiT International
Resolved
The problem has been resolved. We appreciate your understanding.
Posted Oct 14, 2024 - 10:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2024 - 18:34 UTC
Identified
Some customers' invoice dashboards have missing invoice PDF attachments. Our team has identified the issue and is working on a fix.
Posted Sep 30, 2024 - 13:50 UTC
This incident affected: Core Platform (Invoicing).